Project

General

Profile

Anomalie #2639

Liens sur images cassés

Added by da vux almost 9 years ago. Updated almost 9 years ago.

Status:
Fermé
Priority:
Haut
Assignee:
-
Category:
code généré
Target version:
Start date:
04/10/2012
Due date:
% Done:

0%

Resolution:
fixed
Navigateur:

Description

La syntaxe [<img42>->http://example.com] ne fonctionne pas en SPIP-3.0.0-rc.

Exemple : http://plop.grml.eu/spip.php?article1

Ça semble venir de TextWheel qui met des <br class="autobr" /> au milieu des attributs des balises HTML quand il y a des sauts de ligne.

Je mets priorité haute car il s'agit d'un cas assez fréquent et basique.

History

#1 Updated by Fil _ almost 9 years ago

je ne reproduis pas, ni sur spip 2.1+textwheel ni sur spip 3+textwheel

#2 Updated by guytarr ° almost 9 years ago

Chez moi c'est ce saut de ligne qui génère un <br="" > indésirable qui casse le span lorsqu'il y a un alignement
http://zone.spip.org/trac/spip-zone/browser/_core_/plugins/medias/modeles/img.html#L51 (entre la ligne 50 et la 51)

J'ai également un <br class="autobr"> entre le span et le lien.

Sans l'alignement, je n'ai pas "tout" le bug
[<img1>->http://spip.net] : pas de <br="" > qui casse le span, mais un <br class="autobr"> entre le span et le lien (non désiré mais ne casse pas une balise)
[<img1|left>->http://spip.net] : <br="" > qui casse le span et toujours un <br class="autobr"> entre le span et le lien

#3 Updated by cedric - almost 9 years ago

  • Status changed from Nouveau to Fermé
  • Resolution set to fixed

Also available in: Atom PDF