Project

General

Profile

Anomalie #4030

Faire une différence plus grande avec les plugins-dist du futur

Added by Franck D over 3 years ago. Updated about 3 years ago.

Status:
Fermé
Priority:
Bas
Assignee:
-
Start date:
10/23/2017
Due date:
% Done:

0%

Resolution:
fixed
Navigateur:

Description

Hello, :-)
Les plugins-dist de spip 3.3 n'affiche pas spip 3.3 mais spip, exemple:
https://plugins.spip.net/dev.html
et
https://plugins.spip.net/archiviste.html
Il n'y en a que 2 car il s'agit des plug qui sont dans cette liste:
https://zone.spip.org/trac/spip-zone/browser/archivelist_core.txt

En faite, je pense même que cela ne devrait pas afficher, spip mais spip-dev ou autre chose, mais pas un numéro, car, si un jour, la décision est prise que ce n'est plus spip 3.3 ou 3.4, mais spip 4.0, cela sera encore un problème
C'est pour ça que le mieux pour moi, c'est un nom, avec un fond rouge derrière pour que les gens qui aurait quand même idée et les télécharger, soient bien conscient des risquent !

Une autre solution, c'est de faire disparaitre les deux lignes qui concerne spip 3.3 dans le fichier, à voir :-)

plugins.spip.jpg View (139 KB) Franck D , 10/24/2017 05:06 PM

History

#1 Updated by b b about 3 years ago

Je ne comprends rien au ticket :p

On a le même type d'affichage pour SPIP ≥ 3.2.0 et ≤ 3.2.* et SPIP ≥ 3.3.0-dev et ≤ 3.3.*, quel est donc le problème ?

#2 Updated by Franck D about 3 years ago

Il n'y a pas de vrai problème, c'est pour cela que le ticket à un niveau "bas", c'est plutôt une histoire de "présentation", d’apparence :-)
J'ai fais une copie d'écran pour que cela soit plus simple à comprendre :-)
Tu verras que cela affiche "spip" mais c'est trompeur, car comme ça, on pourrait croire que c'est pour toutes les versions de spip alors que non, il s'agit de ceux pour une futur version majeure de spip qui s’appellera "très certainement" spip 3.3, mais qui, temps qu'elle n'est pas dispo, à encore le temps de changer pour un autre numéro, c'est sans doute trop loin pour que nous puissions le dire avec "certitude"

#3 Updated by b b about 3 years ago

< b_b‎ >  ha ok je comprends mieux Francky 
< b_b‎ >  mais la question est plutôt, pourquoi distribuer un zip des plugins dist de la version de dev ?
< b_b‎ >  faut les virer amha

#4 Updated by b b about 3 years ago

  • Status changed from Nouveau to Fermé
  • Resolution set to fixed

Also available in: Atom PDF