Projet

Général

Profil

Anomalie #4162

Pouvoir tester des plugins nécessitant SPIP 3.2.1 dans SPIP 3.2 dev

Ajouté par RealET 🔸 il y a 4 mois. Mis à jour il y a 4 mois.

Statut:
Fermé
Priorité:
Bas
Assigné à:
-
Catégorie:
plugin
Version cible:
Début:
07/08/2018
Echéance:
% réalisé:

100%

Temps estimé:
0.10 h
Resolution:
fixed
Navigateur:

Description

Bonjour,

Le define('_DEV_VERSION_SPIP_COMPAT',"3.2.0"); ne permet pas de tester un plugin demandant SPIP 3.2.1.
Il faudrait mettre define('_DEV_VERSION_SPIP_COMPAT',"3.2.99");

NB : * à la place de 99 ne marche pas.

Révisions associées

Révision 24037 (diff)
Ajouté par bruno@eliaz.fr il y a 4 mois

Fix #4162 : permettre de tester les plugins qui nécessitent SPIP 3.2.1 & + sur le trunk

r22712 indiquait que la constante _DEV_VERSION_SPIP_COMPAT est définie à la dernière version stable pendant la phase de dev du trunk, mais on risque certainement d'oublier de la mettre à jour à chaque release stable, donc autant la définir avec un y de version à 99 (* n'étant pas pris en compte ici)

Historique

#1 Mis à jour par RealET 🔸 il y a 4 mois

Il fallait bien sûr comprendre SPIP 3*.3* dev

#2 Mis à jour par RealET 🔸 il y a 4 mois

C'est ligne 373 de ecrire/inc_version.php qu'il faudrait mettre
define('_DEV_VERSION_SPIP_COMPAT',"3.2.99");

#3 Mis à jour par Anonyme il y a 4 mois

  • Statut changé de Nouveau à Fermé
  • % réalisé changé de 0 à 100

Appliqué par commit r24037.

#4 Mis à jour par b b il y a 4 mois

  • Resolution mis à fixed

Formats disponibles : Atom PDF