Projet

Général

Profil

Anomalie #4267

Pas de virgule dans les chaînes de langue info_une_patate

Ajouté par tcharlss (*´_ゝ`) il y a environ un mois. Mis à jour il y a environ un mois.

Statut:
Rejeté
Priorité:
Normal
Assigné à:
-
Catégorie:
-
Version cible:
-
Début:
09/01/2019
Echéance:
% réalisé:

0%

Resolution:
Navigateur:

Description

Un micro ticket pour un petit truc gênant.

Les 2 chaînes de langues info_un_article et info_un_site se terminent par une virgule : https://core.spip.net/projects/spip/repository/entry/spip/ecrire/lang/ecrire_fr.php#L505

'info_un_article' => 'un article,',
'info_un_site' => 'un site,',

Par contre, la variante au pluriel n'en a pas : https://core.spip.net/projects/spip/repository/entry/spip/ecrire/lang/ecrire_fr.php#L372

'info_nb_articles' => '@nb@ articles',

La virgule pose problème, ces chaînes de langue peuvent être utilisée dans pleins de situations.
Dans les cas où une virgule est nécessaire après, elle devrait être dans le squelette, pas directement dans la chaîne de langue :

<:info_un_article:>, c'est bien, <:info_nb_articles{nb=2}:> articles, c'est mieux.

Nb : je n'ai pas encore cherché où cette chaîne de langue est utilisé dans la dist.

Historique

#1 Mis à jour par tcharlss (*´_ゝ`) il y a environ un mois

On me signale dans l'oreillette que la bonne chaine de langue c'est info_1_article, pas info_un_article.
On peut fermer !

#2 Mis à jour par RastaPopoulos ♥ il y a environ un mois

  • Statut changé de Nouveau à Rejeté

Rejeté ! :D

Formats disponibles : Atom PDF