Project

General

Profile

Evolution #4291

#INFO_INTRODUCTION ne fonctionne pas

Added by tcharlss 🐽 about 2 years ago. Updated 2 months ago.

Status:
En cours
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/15/2019
Due date:
% Done:

0%

Resolution:

Description

cf. https://core.spip.net/projects/spip/repository/entry/spip/ecrire/inc/filtres.php#L4215

#INFO_INTRODUCTION renvoie du vide si l'objet n'a pas de champ 'introduction'.

C'est le fonctionnement normal de la balise : #INFO_truc renvoie par défaut le champ 'truc' de l'objet, avec des exceptions pour deux cas particuliers les plus utilisés : l'URL et le titre, ou là ça appelle des fonctions spécifiques.

Je pense que l'introduction devrait être ajoutée à ces 2 cas particuliers, puisque c'est une des balises courantes de SPIP, et améliorée récemment en plus pour mieux fonctionner avec tous les types d'objets.
Donc ça devrait prendre le champ 'introduction' en priorité s'il existe, et à défaut appeler la fonction qui calcule l'introduction.

Voilà, je ferai un peitt PR à l'occasion.

History

#1 Updated by b b about 2 years ago

  • Target version set to 3.3

Ça me semble bien aussi, fais péter la PR :)

#3 Updated by cedric - 2 months ago

  • Tracker changed from Anomalie to Evolution
  • Status changed from Nouveau to En cours

je crois que la PR est partie en sucette : elle est vide, elle est toujours marquee en WIP, et le commit de merge référencé par gitea n'a rien a voir :p
Mais j'ai grepé dans le code et a ma connaissance c'est pas intégré.

@tcharlss si tu as le code sous la main... :)

#4 Updated by tcharlss 🐽 2 months ago

Bis repetita par ici : https://git.spip.net/spip/spip/pulls/110

(c'est le fork entier d'où était issue la 1ère PR qui est mort)

Also available in: Atom PDF